wordpress版本升级后JS报错和网站功能不正常解决方案

2020-10-1109:28:40wordpress版本升级后JS报错和网站功能不正常解决方案已关闭评论 浏览:2,024次

wordpress升级以后,容易出现JS报错和网站功能不正常的现象,尤其在wordpress更新到5.5以后,版本的升级,导致很多主题兼容性出问题,更多的人使用的主题是免费版的,或者是破解版,这就造成了,你的网站功能各种不正常!

wordpress版本升级后JS报错和网站功能不正常解决方案

有时候,各种排查还找不到原因,其实,这就是在升级之后引起的,那么,对于wordpress版本升级后JS报错和网站功能不正常这个现象,我们究竟应该怎么处理呢?

更换主题,对于很多老站来说,很不现实,毕竟一套主题你用了好几年了,你和你的用户都习惯了,再更换的话,麻烦会很多!

其实,最主要的原因是,有些主题或插件使用了比较老旧的jQuery函数,以前一直都采用jQuery Migrate1.x做兼容处理的,但是现在WordPress 5.5+ 默认禁用了这个兼容库,所以就出现问题了。

对于开发着来说,应该是需要修正自己的主题的兼容性,但是,对于很多使用者来言,并没有开发能力!

其实,wordpress官方也早就考虑到了这个问题,专门开发了一个小插件 Enable jQuery Migrate Helper,只需要安装和启用插件,就可以继续加载 jQuery Migrate1.x,让你的网站避免出现js错误。

使用插件直接安装就可以,比较方便,这样也避免了多数网站的JS报错和发布文正等功能出现不正常!

  • 微信赞赏老师
  • 互联网营销培训课程
  • weinxin
  • 苏春宇微信号
  • 183 6469 9738(手机)
  • weinxin
网络营销培训
苏春宇